Script MyBuntu-fr

Message 1, par Elzen

§ Posté le 11/04/2013 à 0h 40m 36

Il y a quelques temps, j'ai commencé à coder (avec les pieds) un petit script GreaseMonkey pour le site Ubuntu-fr et ses différentes variantes (Kubuntu-fr, Xubuntu-fr, Edubuntu-fr). Le but initial était de permettre, justement, une navigation facilitée entre ces différentes variantes ; puis, au fur et à mesure, j'ai rajouté d'autres petits bouts de trucs, pour finalement aboutir au gros machin informe que vous trouverez ici, et qui peut éventuellement vous rendre l'utilisation du forum plus agréable (moi, en tout cas, j'aime bien).


J'ai la flemme de détailler ce qu'il fait maintenant, d'autant que ce message sera très probablement mis à jour à chaque fois que je ferai une modif sur ledit script ; si vous voulez un peut d'historique dessus en attendant que j'ai le courage de m'y mettre, voyez sur le forum Ubuntu lui-même. Je crée simplement cette page ici pour retrouver ça plus facilement (et aussi pour peupler un peu cette section désespérément vide).

Message 2, par cqfd93

§ Posté le 13/04/2015 à 17h 36m 28

salut Elzen !


j'ai l'impression que la nouvelle version ne marche pas mieux que l'ancienne : aucune des options ne reste cochée après un rafraîchissement de la page en cours et aucune ne semble de toutes façons être prise en compte. Le script est-il supposé être actif immédiatement après installation, sans redémarrage de Firefox ?

Message 3, par Elzen

§ Posté le 13/04/2015 à 17h 47m 58

Okay, c'est réglé.


Depuis la dernière retouche de ce script, GreaseMonkey a changé sa politique de sécurité et demande de déclarer en en-tête du script les fonctions particulières utilisées. Ça concerne, notamment, l'enregistrement de cookies multi-domaines, que j'utilise pour éviter que le script ait des réglages différents si on passe, par exemple, de kubuntu-fr à xubuntu-fr.

Du coup, il suffisait que je rajoute les déclarations adéquates en en-tête, et tout est réglé. Je l'avais fait chez moi, mais j'avais oublié de mettre le nouveau fichier en ligne. Si tu le récupères maintenant, ça devrait remarcher.

Message 4, par cqfd93

§ Posté le 13/04/2015 à 18h 34m 16

merci Elzen !

Message 5, par Elzen

§ Posté le 16/08/2015 à 20h 55m 27

De rien ^^ Et okay, c'est prêt 😊


Je viens de reprendre ce script et de le séparer en plusieurs fichiers pour rendre ça plus lisible et plus maintenable que ça ne l'était jusque là. J'en ai profité pour changer un poil la présentation, et ajouter quelques options. Il suffit de cliquer sur le lien ci-dessus pour installer tout ça ; en revanche, vous aurez besoin de redéfinir vos choix en mettant à jour.

(Note : Greasemonkey pensera probablement qu'il s'agit d'un script différent : supprimez l'ancien avant d'installer celui-ci)


Entre autres ajouts intéressants, la possibilité d'uploader des images (vers un hébergeur tiers, Toile-Libre et TdCT.org étant les seuls intégrés pour l'instant, n'hésitez pas à signaler si vous en connaissez d'autres sur le même modèle) directement depuis la page de rédaction est désormais fonctionnelle.

(La coloration syntaxique du BBCode, quant à elle, est toujours une vraie catastrophe, les coups de main sont les bienvenus)

Message 6, par Mike11310

§ Posté le 16/09/2015 à 18h 21m 31

Bonjour;

Comment installer ce "Truc" qui semble très intéressant?

Je voudrais lire mes messages prioritairement sur le site UBUNTU.


Merci

Message 7, par Elzen

§ Posté le 16/09/2015 à 18h 27m 29

Salut,


ça se fait en quelques étapes 😊


D'abord, installer GreaseMonkey, ou l'équivalent pour ton navigateur.

Ensuite, une fois ce dernier activé (ça peut nécessiter un redémarrage du navigateur), cliquer sur le lien « ici » du premier message de cette page, ce qui ouvre une popup proposant l'installation.


Une fois ceci fait, il faut aller sur l'un des sites d'Ubuntu-fr (page d'accueil, forum ou doc), et cliquer sur l'astérisque qui s'affiche à côté du logo, en haut à gauche de la page, ce qui donne accès aux différentes options.

Message 8, par Pierrecastor

§ Posté le 30/09/2015 à 22h 46m 06

Salut,


Merci pour ton script, notamment pour la fonction d'upload d'image qui me permet de gagner pas mal de temps et de confort sur le topic de "Quel film c'est". Très pratique.


PS : Drôle la captcha ou il faut compter le nombre de message, je n'avais encore jamais vu ce principe. :-)

Message 9, par Elzen

§ Posté le 01/10/2015 à 8h 41m 24

De rien 😊


Je m'étais cassé les dents un moment sur cette fonction d'upload d'images, mais GreaseMonkey simplifie pas mal les choses par rapport au JavaScript directement intégré dans les pages. Donc, j'suis content que ça marche aussi ^^


Et ouais, j'ai fait original sur le captcha. Le but était de faire un truc suffisamment rare et tordu pour que les spambots loupent leurs coups, mais suffisamment simple pour pouvoir être automatisé au cas où il y aurait besoin de concevoir un truc spécifique à ce site. D'ailleurs, si tu vas sur la page de réglages, on peut activer un script qui le zappe automatiquement.

Message 10, par Zuzur N C

§ Posté le 21/04/2016 à 11h 02m 37

[MegaUp Power Activated]


Bonjour,


Je viens de découvrir ton script et du coup je voulais te faire un retour.

Je ne l'ai pas pas vraiment exploité encore (je viens genre tout juste de l'installer, d'ailleurs en lisant tout les posts de du forum ubuntu-fr.org j'ai du installer au moins 4 versions différentes de ton script xDD) mais je voulais quand même te dire que au moins visuellement et au niveau de la balise color tout fonctionne.


Voilà voilà !

Message 11, par Elzen

§ Posté le 21/04/2016 à 11h 13m 47

Salut, merci 😊


À l'avenir, tu peux noter cette page et n'utiliser que le lien présent dans le premier post : c'est celui-là que je mets à jour au fur et à mesure.


D'ailleurs, il y aurait du boulot à faire sur la version actuelle, certains trucs ne marchent plus très bien depuis la dernière mise à jour du forum, mais je n'ai pas trop le temps de m'en occuper pour l'instant.

Message 12, par Elzen

§ Posté le 04/05/2016 à 17h 32m 55

J'en profite (oui, bon, voilà, quoi) que je viens enfin de réparer lesdits trucs qui ne marchaient plus très bien (à savoir, principalement quelques options d'affichages, et puis, un petit soucis concernant le choix du moteur par défaut).


N'hésitez pas à faire part de vos retours si vous en avez 😊

Message 13, par Janpolo

§ Posté le 08/09/2016 à 10h 18m 56

Bonjour.


J'utilise votre script avec beaucoup d'intérêt (ras le bol du pistage de Google) depuis un an ou deux.

Cependant depuis le début, je rencontre la difficulté suivante. Pour que le script soit actif et change de moteur de recherche, je dois :

- lancer une recherche avec Google, le moteur de recherche d'ubuntu-fr.org par défaut

- cliquer sur un des liens proposés

- revenir à la page d'accueil d'Ubuntu pour enfin avoir le bon moteur de recherche (l'astérisque aparaît à ce moment-là).


Est-ce que j'ai raté quelque chose pour que le script soit actif dés l'accès au site ubuntu-fr.org ?


Merci.

Message 14, par Elzen

§ Posté le 08/09/2016 à 13h 17m 21

Hum, normalement, le script est actif à partir du moment où l'on est sur une page d'Ubuntu-fr, peu importe la façon dont on y est arrivé. À vue de nez, je n'arrive pas à reproduire le soucis, chez moi l'astérisque (et le reste) s'affichent bien correctement à chaque fois…


Donc en l'état, je ne vois pas trop d'où peut venir le soucis.



Néanmoins, s'il s'agit uniquement d'utiliser un autre moteur que Google, le script n'est plus nécessaire pour le forum (qui utilise startpage par défaut depuis un moment). Ceci ne semble cependant pâs concerner le reste du site, je vais faire remonter l'information.

Message 15, par Pierrecastor

§ Posté le 29/09/2016 à 11h 00m 47

Un petit truc comme ça, un petit ajout d'une date et d'un numéro de version en début de script aiderai à s'y retrouver. ;-)


Autre chose, j'ai fais quelques essaies ici :


https://forum.ubuntu-fr.org/viewtopic.php?pid=21598193


Le changement automatique en lien relatif ne marche que dans la fenêtre de modification d'un message, impossible de le faire marcher lors du premier envoi d'un message, que ce sois dans la réponse rapide ou en cliquant sur répondre.


Castorement votre

Message 16, par Janpolo

§ Posté le 07/12/2016 à 18h 22m 53

Bonjour,


Je reviens sur la question posée le 8 septembre. Je suis finalement arrivé à utiliser directement le moteur de recherche "Duckduckgo" dés l'accès à Ubuntu-fr.org.

Dans les préférences du script, pages autorisées, j'ai rajouté https://ubuntu-fr.org/ (et http://xubuntu-fr.org/ pour vérifier que cela fonctionnait avec un autre site). L'astérisque apparaît dés l'accès aux sites et je peux rechercher via le moteur de recherche choisi.


Cordialement.

Message 17, par Janpolo

§ Posté le 07/12/2016 à 19h 40m 43

Rebonjour.


Désolé mon message précédent était erroné. En effet :

AVEC https://ubuntu-fr.org/ dans les Préférences/Paramètres de l'utilisateur/pages autorisées :


L'astérisque apparaît en se connectant à la page https://ubuntu-fr.org et le nouveau moteur de recherche (Duckduckgo) est actif. Mais il manque ubuntu-fr dans la recherche "bépo" dans "Site" :


https://duckduckgo.com/?q=b%25E9po+site%253Adoc.org&ia=web

bépo site:doc.org


Idem avec Google

https://www.google.fr/search?q=b%E9po+site%3Adoc.org&gws_rd=ssl

bépo site:doc.org


SANS https://ubuntu-fr.org/ dans Préférences/Paramètres de l'utilisateur/Pages autorisées :


L'astérisque n'apparaît pas en se connectant à la page https://ubuntu-fr.org ; la requête de recherche est correcte sauf le moteur de recherche qui reste sur Google :


https://www.google.fr/search?q=b%C3%A9po+site%3Adoc.ubuntu-fr.org

bépo site:doc.ubuntu-fr.org.


A moins que ce ne soit évident, pas besoin de vous pencher dessus. Mais, bon, Google me bloque avec une fenêtre que je dois valider pour étudier ses règles de confidentialité. Il est inadmissible qu'Ubuntu admette ce genre de blocage pour consulter son site.


Cordialement.

Message 18, par Janpolo

§ Posté le 11/12/2016 à 23h 46m 16

Bonjour.

Finalement, je suis arrivé à mes fins en allant directement sur une page de la documentation ou du forum d'ubuntu-fr.org (comme https://doc.ubuntu-fr.org/tutoriel/bepo). L'étoile apparaît et le moteur de recherche n'est plus Google. La page d'accueil utilise Google comme indiqué dans mon message du 8 septembre et l'étoile n'est pas visible.

Cordialement

Envoyer une réponse